Issues with KWA USP (Newest licensed version)

From Classic Airsoft to recent GBBs
User avatar
AirsoftFTW
Dragoon
Posts: 523
Joined: Thu Aug 06, 2009 4:04 pm
HumanQuestion: Yes
HumanQuestion2: yes
Location: In my chair.

Issues with KWA USP (Newest licensed version)

Postby AirsoftFTW » Sun Jun 01, 2014 11:29 am

Bought this little monster a week or so ago, along with the AI adapter, ICS silicone spray, and two bags of KSC perfects.
Soon as I got the thing out of the box, I used a generous amount of the ISC spray on all contact points on the gun. Made sure the action was nice and quick. Put a drop or two of the liquid lube on the propane can reservoir as instructed, gassed up a magazine, loaded it up, and everything was fine. Kick was strong, shots were straight, everything was working great. The first mag I put through didn't last quite as long on gas, so I filled it back up and went to shoot it again. This time, even though the magazine was fully pressurized, the slide was not moving back all the way, and BB's were not being loaded in the chamber. I pulled the trigger, and the slide only moved back about in inch or so. Took it back inside, and along the rail and scattered inside were little pieces of rubber/plastic debris. Looked nice and chewed up. I removed all the ones I could find, cleaned the old lubricant off, applied new lubricant, went to test it again and I'm still having the same problem. When the trigger is pulled, the slide refuses to kick back all the way. Any ideas?
Do not try to read this signature. I wrote all of the important stuff in invisible ink. You'll have to squirt lemon juice on your screen to be able to read it.
Jonny Scotland
Pawn
Posts: 35
Joined: Fri Dec 21, 2012 12:37 pm
HumanQuestion: Yes
HumanQuestion2: yes

Re: Issues with KWA USP (Newest licensed version)

Postby Jonny Scotland » Fri Jun 06, 2014 12:45 pm

I have the match version and the only piece of rubber in the whole gun is the hop up sleeve (a ball bearing applies the pressure)

Mine half cycled a lot and it was second hand

Took it all apart and the hop rubber had a massive chunk missing

Replaced it and works fine but due to the ambidextrous slide release being attached via allan key it won't lock back if its too tight

Edit- there is another piece of rubber in the gun (not including magazine)

Its green however and is in the blowback housing
User avatar
AirsoftFTW
Dragoon
Posts: 523
Joined: Thu Aug 06, 2009 4:04 pm
HumanQuestion: Yes
HumanQuestion2: yes
Location: In my chair.

Re: Issues with KWA USP (Newest licensed version)

Postby AirsoftFTW » Sun Jun 08, 2014 12:05 pm

Fahhk.
I really don't want to have to deal with sending it back, but I've never really worked with GBB's before, so I have no idea where to look for the issue.
Do not try to read this signature. I wrote all of the important stuff in invisible ink. You'll have to squirt lemon juice on your screen to be able to read it.
Jonny Scotland
Pawn
Posts: 35
Joined: Fri Dec 21, 2012 12:37 pm
HumanQuestion: Yes
HumanQuestion2: yes

Re: Issues with KWA USP (Newest licensed version)

Postby Jonny Scotland » Tue Jun 10, 2014 4:02 pm

have you taken the inner barrel and outer barrel out of it before?

spring guide might be different to mine but it comes out the same way as real steel

Getting the barrel assembly out is easier, once its out separate the outer barrel (should just slide off)
And look for any deformation with the hop up bucking through the hop unit and inner barrel
(black rubber sleeve around barrel)

Return to “Gas Guns”

Who is online

Users browsing this forum: No registered users and 1 guest